POJ1286 Necklace of Beads(Polya定理)

2018-07-12 07:32:39来源:博客园 阅读 ()

新老客户大回馈,云服务器低至5折

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9359   Accepted: 3862

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39

Source

Xi'an 2002

 

哈哈我是来骗访问量的。这题和上一题一毛一样

只不过需要把颜色数改为$3$然后换成LLd

上一篇:https://www.cnblogs.com/zwfymqz/p/9294983.html

 

#include<algorithm>
#include<iostream>
#include<cstdio> 
#define int long long 
using namespace std;
int C = 3, N;
int fastpow(int a, int p) {
    int base = 1;
    while(p) {
        if(p & 1) base = base * a;
        a = a * a; p >>= 1;
    }
    return base;
}
main() {
    while(cin >> N) {
        if(N == -1) break;
        if(N <= 0) {printf("0\n"); continue;}
        int ans = 0;
        for(int i = 1; i <= N; i++) ans += fastpow(C, __gcd(i, N));
        if(N & 1) ans = ans + N * fastpow(C, (N + 1) / 2);
        else ans = ans + N / 2  * (fastpow(C, (N + 2) / 2) + fastpow(C, N / 2));
        cout << ans / 2 / N << endl;
    }
}

 

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:POJ2409 Let it Bead(Polya定理)

下一篇:BZOJ1004: [HNOI2008]Cards(Burnside引理 背包dp)