HDU 4764 Stone(巴什博奕)

2018-06-17 21:12:05来源:未知 阅读 ()

新老客户大回馈,云服务器低至5折

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2026    Accepted Submission(s): 1428


Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.
 

 

Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.
 

 

Output
For each case, print the winner's name in a single line.
 

 

Sample Input
1 1 30 3 10 2 0 0
 

 

Sample Output
Jiang Tang Jiang
 

 

Source
2013 ACM/ICPC Asia Regional Changchun Online
 

 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  6263 6262 6261 6260 6259 
 
 
我们可以把模型抽象一下
有$n-1$个石子,一个人最多拿$k$个,问最后谁赢
——》裸的巴什博奕
 
 
#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN=1e6+10,INF=1e9+10;
int main()
{
    #ifdef WIN32
    freopen("a.in","r",stdin);
    #else
    #endif
    int x,y;
    while(scanf("%d%d",&x,&y))
    {
        if(x==0&&y==0) break;
        if( (x-1)%(y+1)==0 ) printf("Jiang\n");
        else                  printf("Tang\n");
    }
    return 0;
}

 

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:BZOJ1299: [LLH邀请赛]巧克力棒(Nim游戏)

下一篇:vs2017 如何定位C++内存泄漏