1 . Robberies (hdu 2955)

2018-06-17 23:55:23来源:未知 阅读 ()

新老客户大回馈,云服务器低至5折

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

 


Input

 

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

 

 


Output

 

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

 

 


Sample Input

 

3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05

 

 


Sample Output

 

2 4 6

 

 

题意 小偷有个总的逃跑概率,每个银行有一个钱数和逃跑概率,问在总的逃跑概率下能最多获得多少钱?

思路:开始有0-1背包写,把概率扩大100倍,wa了,重改思路。把总价格当容量,被抓的概率为价值 在被抓的概率大于总概率时的容量为多少

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <math.h>
#include <vector>
using namespace std;
#define N 10100
#define ll long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932
#define met(a,b) memset(a,b,sizeof(a));
vector<vector<int> >Q;
double w[N],dp[N];
int v[N];
int main()
{
    int t,sum,n;
    double p;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%lf %d",&p,&n);
        p=1-p;
        for(int i=1;i<=n;i++)
        {
            scanf("%d %lf",&v[i],&w[i]);
              w[i]=1-w[i];
              sum+=v[i];
        }
        met(dp,0);
        dp[0]=1;
        for(int i=1;i<=n;i++)
        {
            for(int j=sum;j>=v[i];j--)
                dp[j]=max(dp[j],dp[j-v[i]]*w[i]);
        }
        for(int i=sum;i>=0;i--)
        {
            if(dp[i]>=p)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}

 

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:C/C++ 一些常用的运算符

下一篇:POJ 1775 Sum of Factorials 数论,基础题