poj-1611-The Suspects

2018-06-17 23:45:19来源:未知 阅读 ()

新老客户大回馈,云服务器低至5折

The Suspects
Time Limit: 1000MS   Memory Limit: 20000K
Total Submissions: 34284   Accepted: 16642

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题目大意:找0所在集合的成员个数
题目链接:http://poj.org/problem?id=1611

代码:
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int f[30008];
int num[30008];
int find(int n)
{
    if(n!=f[n])
    f[n]=find(f[n]);
    return f[n];
}
int main()
{ int n,m;
    while(cin>>n>>m)
    {  if(n==0&&m==0)
       break;
        for(int i=0;i<n;i++)
        {f[i]=i;num[i]=1;}
        int a,b,c;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            for(int j=1;j<a;j++)
            {
                scanf("%d",&c);
                int b1=find(b),c1=find(c);
                if(b1!=c1)
                {
                    f[c1]=b1;
                    num[b1]+=num[c1];
                }
            }
        }
        cout<<num[find(0)]<<endl;
    }

    return 0;
}
 

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:【菜鸟玩Linux开发】在Linux中使用VS Code编译调试C++项目

下一篇:poj-2236-Wireless Network