HDU 1028(母函数)

2018-06-17 23:43:20来源:未知 阅读 ()

新老客户大回馈,云服务器低至5折

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
     C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests
Author jxust hsy
Mail Mail 0(0)
Control Panel Control Panel 
Sign Out Sign Out
 

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19181    Accepted Submission(s): 13477


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627

题意:给你一个正整数n,将该正整数拆分成若干整数的和,问你共有多少不同的拆分方法?

#include<bits/stdc++.h>
using namespace std;
int c1[205],c2[205];//c1用于记录各项前面的系数,c2用于记录中间值
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        //共有n个括号,先处理第一个括号,第一个括号里每一项的系数都是1;
        for(int i=0;i<=n;i++)
        {
            c1[i]=1;
            c2[i]=0;
        }
        //因为共有n个括号,i表示正在处理第i个括号
        for(int i=2;i<=n;i++)
        {
            //j表示正在处理第i个括号里的第就项,
            for(int j=0;j<=(n);j++)
            {
                for(int k=0;k+j<=n;k+=i)
                {
                    c2[j+k]+=c1[j];
                }
            }
            for(int j=0;j<=(n);j++)
            {
                c1[j]=c2[j];
                c2[j]=0;
            }
        }
        printf("%d\n",c1[n]);
    }
    return 0;
}

 

 

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:2016弱校联盟十一专场10.3---Similarity of Subtrees(深搜+hash

下一篇:Gym 101102D---Rectangles(单调栈)