hdu 5573---Binary Tree(构造)

2018-06-17 22:26:19来源:未知 阅读 ()

新老客户大回馈,云服务器低至5折

题目链接

 

Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say froot=1.

And for each node u, labels as fu, the left child is fu×2 and right child is fu×2+1. The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly Nsoul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is fx (remember froot=1), he can choose to increase his number of soul gem by fx, or decrease it by fx.

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N, then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given NK, help the King find a way to collect exactly N soul gems by visiting exactly K nodes.
 
Input
First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers N and K, which indicates soul gems the frog king want to collect and number of nodes he can visit.

 1T100.

 1N109.

 N2K260.
 
Output
For every test case, you should output "Case #x:" first, where x indicates the case number and counts from 1.
Then K lines follows, each line is formated as 'a b', where a is node label of the node the frog visited, and b is either '+' or '-' which means he increases / decreases his number by a.
It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

Sample Input
2
5 3
10 4
 
Sample Output
Case #1:
1 +
3 -
7 +
Case #2:
1 +
3 +
6 -
12 +
 
题意:输入N , K, 从二叉树根节点开始向下走K层(每次只能选择左儿子或右儿子),节点的值即为节点序号,每个节点的值可以可以取正负(即走到某个节点要么加上这个节点的值,要么减去这个节点的值),输出一条路径,且其值为N。
 
思路:
           

           可以由左侧的点就可以组成1~2^k的值,而题目中数据范围N<=2^k 所以本题只需考虑最左侧的点就行了(最后一个点为2^(k-1)或2^(k-1)+1  可以根据N奇偶特判),现在确定了由最左边的数构成,那么还需要确定每个数的符号 。由上图可以发现1,2,4,8,……2^k这样的数列,1+2+4+8+……+2^(k-1)<2^(k+1) ,又1+2+4+8=15 【0000=0】,(-1)+2+4+8=13 【0001=1】,1+(-2)+4+8=11 【0010=2】,(-1)+(-2)+4+8=9 【0011=3】,1+2+(-4)+8=7 【0100=4】  …… 所以数列中的数根据符号与二进制有关,如上图所述:10排第5个,共8个数,8-5=3 【0011】,所以1和2取负号,4和9取正号。

 

代码如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long LL;

int main()
{
    int T,Case=1;
    cin>>T;
    int N,k;
    while(T--)
    {
       printf("Case #%d:\n",Case++);
       scanf("%d%d",&N,&k);
       LL n=1<<(k-1);
       LL x=n-(N+1)/2;
       LL tmp=1;
       for(int i=1;i<k;i++)
       {
           printf("%lld ",tmp);
           if(x&tmp) puts("-");
           else puts("+");
           tmp<<=1;
       }
       if(N&1) printf("%lld +\n",tmp);
       else printf("%lld +\n",tmp+1);
    }
    return 0;
}

 

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:P1165 日志分析

下一篇:P3373 【模板】线段树 2 区间求和 区间乘 区间加