hdu_3123_GCC

2018-06-17 21:32:20来源:未知 阅读 ()

新老客户大回馈,云服务器低至5折

The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m

InputThe first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.
OutputOutput the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000
Sample Input

1
10 861017

Sample Output

593846

唬人的题目,当x>=m, x! =0 mod m
我们就是在求小于m的 ∑x!
提取公因式化简得
1+(1*2)+(1*2*3)+.....+(1*2*3*....*x)=1*(1+2*(1+3*(.....x-1*(1+x))))
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
int main()
{
    char n[105];
    int m,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",n);
        getchar();
        scanf("%d",&m);
        int s=strlen(n);
        int n1=0;
        for(int i=0;i<s;i++)
        {
            n1*=10;
            n1+=n[i]-'0';
            if(n1>=m)
                break;
        }
        long long ans;
        if(n1>=m)
        {
            ans=m-1;
            for(int i=m-2;i>=1;i--)
            {
                ans=(ans+1)%m*i%m;
            }
        }
        else
        {
            ans=n1;
            for(int i=n1-1;i>=1;i--)
            {
                ans=(ans+1)%m*i%m;
            }
        }
        ans++;
        cout<<ans%m<<endl;

    }
}

  

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:洛谷P2286 [HNOI2004]宠物收养场

下一篇:VS2013+QT写的Action或按钮明明没有按下,却会调用