# 5RIP unicast without using Neighbor - NAT …
2008-02-23 04:53:30来源:互联网 阅读 ()
interface Loopback0
ip address 20.1.1.1 255.255.255.0
!
interface Ethernet0/0
ip address 12.1.1.2 255.255.255.0
ip nat outside
!
router rip
version 2
passive-interface Loopback0
network 12.0.0.0
network 20.0.0.0
!
ip nat outside source static udp 12.1.1.1 520 224.0.0.0 520 extendable
r2#sh ip route
20.0.0.0/24 is subnetted, 1 subnets
C 20.1.1.0 is directly connected, Loopback0
R 10.0.0.0/8 [120/1] via 12.1.1.1, 00:00:16, Ethernet0/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Ethernet0/0
r2#sh ip nat trans
Pro Inside global Inside local Outside local Outside global
udp --- --- 224.0.0.0:520 12.1.1.1:520
r2#
r2#deb ip nat
IP NAT debugging is on
r2#deb ip rip
RIP protocol debugging is on
r2#
*Mar 1 02:41:50.797: RIP: received v2 update from 12.1.1.1 on Ethernet0/0
*Mar 1 02:41:50.797: 10.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar 1 02:42:04.392: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (12.1.1.2)
*Mar 1 02:42:04.392: RIP: build update entries
*Mar 1 02:42:04.392: 20.0.0.0/8 via 0.0.0.0, metric 1, tag 0
r2#
*Mar 1 02:42:20.173: RIP: received v2 update from 12.1.1.1 on Ethernet0/0
*Mar 1 02:42:20.177: 10.0.0.0/8 via 0.0.0.0 in 1 hops
===================================================================
!
hostname r1
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0/0
ip address 12.1.1.1 255.255.255.0
!
router rip
version 2
passive-interface Loopback0
network 10.0.0.0
network 12.0.0.0
r1#deb ip rip
RIP protocol debugging is on
r1#deb ip pac
IP packet debugging is on
r1#
*Mar 1 15:33:04.893: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (12.1.1.1)
*Mar 1 15:33:04.893: RIP: build update entries
*Mar 1 15:33:04.893: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 15:33:04.893: IP: s=12.1.1.1 (local), d=224.0.0.9 (Ethernet0/0), len 52, sending broad/multicast
*Mar 1 15:33:13.936: IP: s=12.1.1.2 (Ethernet0/0), d=224.0.0.9, len 52, rcvd 2
*Mar 1 15:33:13.936: RIP: received v2 update from 12.1.1.2 on Ethernet0/0
*Mar 1 15:33:13.936: 20.0.0.0/8 via 0.0.0.0 in 1 hops
r1#
*Mar 1 15:33:33.043: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (12.1.1.1)
*Mar 1 15:33:33.043: RIP: build update entries
*Mar 1 15:33:33.043: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 15:33:33.043: IP: s=12.1.1.1 (local), d=224.0.0.9 (Ethernet0/0), len 52, sending broad/multicast
*Mar 1 15:33:40.692: IP: s=12.1.1.2 (Ethernet0/0), d=224.0.0.9, len 52, rcvd 2
*Mar 1 15:33:40.692: RIP: received v2 update from 12.1.1.2 on Ethernet0/0
*Mar 1 15:33:40.696: 20.0.0.0/8 via 0.0.0.0 in 1 hops
r1#
r1#
r1#sh ip route
R 20.0.0.0/8 [120/1] via 12.1.1.2, 00:00:20, Ethernet0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Ethernet0/0
标签:
版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有
IDC资讯: 主机资讯 注册资讯 托管资讯 vps资讯 网站建设
网站运营: 建站经验 策划盈利 搜索优化 网站推广 免费资源
网络编程: Asp.Net编程 Asp编程 Php编程 Xml编程 Access Mssql Mysql 其它
服务器技术: Web服务器 Ftp服务器 Mail服务器 Dns服务器 安全防护
软件技巧: 其它软件 Word Excel Powerpoint Ghost Vista QQ空间 QQ FlashGet 迅雷
网页制作: FrontPages Dreamweaver Javascript css photoshop fireworks Flash