FreeBSD模块开发最简单示例
2009-05-13 15:12:28来源:未知 阅读 ()
举个例子,可以将网卡驱动编译成单独的模块,而不是将网卡编导内核中去,这样内核能够减小体积,效率更高,在需要的时候可以动态的加载到内核中去。使用kldload命令,kldunload命令卸载模块。kldstat命令查看当前运行的模块。
下面给出一个最简单的模块实例:(/usr/src/share/example/kld)
/*-
* Copyright (c) 1999 Assar Westerlund
* All rights reserved.
*
* Redistribution and use in source and binary forms, with or without
* modification, are permitted provided that the following conditions
* are met:
* 1. Redistributions of source code must retain the above copyright
* notice, this list of conditions and the following disclaimer.
* 2. Redistributions in binary form must reproduce the above copyright
* notice, this list of conditions and the following disclaimer in the
* documentation and/or other materials provided with the distribution.
*
* THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
* ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
* ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
* FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
* DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
* OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
* SUCH DAMAGE.
*
* $FreeBSD: src/share/examples/kld/syscall/module/syscall.c,v 1.5 2007/07/22 06:48:34 kevlo Exp $
*/
#include sys/types.h>
#include sys/param.h>
#include sys/proc.h>
#include sys/module.h>
#include sys/sysproto.h>
#include sys/sysent.h>
#include sys/kernel.h>
#include sys/systm.h>
/*
* The function for implementing the syscall.
*/
static int
hello (struct thread *td, void *arg)
{
printf ("hello kernel\n");
return 0;
}
/*
* The `sysent' for the new syscall
*/
static struct sysent hello_sysent = {
0, /* sy_narg */
hello /* sy_call */
};
/*
* The offset in sysent where the syscall is allocated.
*/
static int offset = NO_SYSCALL;
/*
* The function called at load/unload.
*/
static int
load (struct module *module, int cmd, void *arg)
标签:
版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有
- Introducing NetBSD 5.0 by Andrew Doran 2009-05-13
- 见笑了,问一个很简单的问题 2009-05-13
- portsnap的几种简单用法 2009-05-13
- 【视频棋牌游戏】可运营的地方性棋牌游戏定制开发 2009-05-13
- 嵌入式开发专题:C语言嵌入式系统编程修炼(转) 2009-05-13
IDC资讯: 主机资讯 注册资讯 托管资讯 vps资讯 网站建设
网站运营: 建站经验 策划盈利 搜索优化 网站推广 免费资源
网络编程: Asp.Net编程 Asp编程 Php编程 Xml编程 Access Mssql Mysql 其它
服务器技术: Web服务器 Ftp服务器 Mail服务器 Dns服务器 安全防护
软件技巧: 其它软件 Word Excel Powerpoint Ghost Vista QQ空间 QQ FlashGet 迅雷
网页制作: FrontPages Dreamweaver Javascript css photoshop fireworks Flash